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1 Description of the problem 

An example of a circular cylindrical storage tank resting on an isotropic elastic half space soil 

medium is selected to and illustrate some features of ELPLA for analyzing circular cylindrical shell 

elements. 

2 Tank geometry and properties 

A circular cylindrical tank of an inner diameter of d = 20 [m] and a height of H = 10 [m]  

is considered as shown in Figure 9.1. Thicknesses of the wall and the base are different.  

The thickness of the tank wall is tw = 0.2 [m] and that of the base is tb = 0.5 [m]. The tank is filled  

with water. Figure 9.1 shows the storage tank, while the tank material and unit weight of the water 

are listed in Table 9.1. The data of soil medium under the base of the tank are shown in Table 9.2. 

 

 
Figure 9.1 Circular cylindrical tank resting on an isotropic elastic soil medium 

Table 9.1 Tank material and water unit weight  

Modulus of Elasticity of the tank material   Ec = 2×107 [kN/ m2] 

Poisson's ratio of the tank material     νb = 0.16  [-] 

Unit weight of the tank material    γb = 24  [kN/ m3] 

Unit weight of the water     γw  = 10.19 [kN/ m3] 

Table 9.2 Soil data  

Modulus of Elasticity of the soil medium   E = 20000 [kN/m2] 

Poisson's ratio of the soil medium     νs = 0.2  [-] 

Ec = 2 ×107 [kN/ m2] 

νc = 0.16  [-] 

γb = 24  [kN/ m3] 

γw = 10.19 [kN/ m3] 

 

H
 =
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0
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m
] 
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Isotropic elastic soil medium 

E = 20000 [kN/ m2] 

νs = 0.2      [-] 
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3 Numerical Analysis 

In order to analyze a water storage tank resting on an isotropic elastic half space soil medium using 

ELPLA, this example shown in Figure 9.1 is analyzed. The height of the tank is divided  

into 50 equal segments, each of 0.20 [m], as shown in Figure 9.2, while the half base of the tank is 

divided into 50 equal segments, each of 0.20 [m]. 

 

 
Figure 9.2 Finite element mesh of the tank 
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4 Creating the project 

In this section, the user will learn how to create a project for analyzing a tank resting on an isotropic 

elastic half space soil medium. The project will be processed gradually to show the possibilities  

and abilities of the program. To enter the data of the example, follow the instructions and steps  

in the next paragraphs. 

4.1 Calculation method 

Choose "New Project" command from the "File" menu. The following "Calculation Methods" 

wizard appears, Figure 9.3. This wizard will help the user to define the analysis type  

and the calculation method of the problem through a series of forms. The first form of "Calculation 

Methods" wizard is the "Analysis Type" Form (Figure 9.3). 

 

 
Figure 9.3 "Analysis Type" Form 

In the "Analysis Type" Form in Figure 9.3, define the analysis type of the problem. As the analysis 

type is a tank resting on an isotropic elastic half space soil medium problem,  

select "Analysis of rotational Shell" button, and check "Shell with a raft foundation" option, 

then click "Next" button to go to the next Form. After clicking "Next" button, the "Calculation 

Method" Form appears, Figure 9.4. 
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To define the calculation method: 

 

- Select the calculation method "4-Modification of Modulus of Subgrade Reaction by Iteration" 

- To determine the subsoil model, select "Half Space model"  

- Click "Next" button to go to the next Form 

 

 
Figure 9.4 "Calculation Method" Form 

The last Form in the wizard is the "Options" Form, Figure 9.5. In this Form, ELPLA displays some 

available options corresponding to the chosen numerical model, which differ from model to other. 

Since no option will be considered in the analysis, click the "Save" button. 
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Figure 9.5 "Options" Form 

After clicking "Save" button, the "Save as" dialog box appears, Figure 9.6. In this dialog box 

type a file name for the current project in "File name" edit box. For example,  

type "Tank with different base thickness". ELPLA will use automatically this file name  

in all reading and writing processes. 
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Figure 9.6 "Save as" dialog box 

ELPLA will activate the “Data” Tab. In addition, the file name of the current project [Tank with 

different base thickness] will be displayed instead of the word [Untitled] in the ELPLA title bar. 
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4.2 Project identification 

The user can enter three lines of texts to describe the problem and the basic information about the task. 

These texts are required only for printing and plotting the data and results. Project identification 

does not play any role in the analysis. The three lines are optionally and maybe not completely entered. 

To identify the project, choose "Project Identification" command from the “Data” Tab. 

The dialog box in Figure 9.7 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box:  

"Analysis of a tank resting on a half space soil medium" 

- Type the date of the project in the "Date" edit box 

- Type "Axisymmetric Structures and Tanks" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 9.7 "Project Identification" dialog box 

4.3 FE-Net data 

For the given problem, a circular cylindrical tank of an inner diameter of d = 20 [m]  

and a height of H = 10 [m], the height of the tank is divided into 50 equal segments, each of 0.20 [m], 

while the half base of the tank is divided into 50 equal segments, each of 0.20 [m].  

To define the FE-Net for this tank, choose "FE-Net Data" command from the “Data” Tab.  

"Analysis of rotational shell" wizard appears as shown in Figure 9.8. This wizard will guide you 

through the steps required to generate a FE-Net. 

 

The first Form of the wizard is the "Shell type" Form, which contains a group of templates of 

different shapes of nets. These net templates are used to generate standard nets. 
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Figure 9.8 "Analysis of rotational shell" wizard with "Shell type" Form 

To generate the FE-Net 

 

- In the "Shell type" options choose "Cylindrical shell" button 

- Type 10 in the "Height" edit box 

- Type 10 in the "Radius" edit box 

- Type 50 in the "Number of segments" edit box 

- Click "Next" button to go to the next Form 

 

After clicking "Next" in "Analysis of rotational shell" wizard, the following "Cylindrical shell" 

Form appears Figure 9.9, ELPLA divides the height of the tank into 50 equal segments,  

the user can edit the data of the segments individually by using "Modify" button, or all of them  

by using "In Table" button, if it is necessary. 
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Figure 9.9 "Cylindrical shell" Form 

After clicking "Next" in "Analysis of rotational shell" wizard, the following "Net of Base" 

Form appears Figure 9.10. 
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To edit the grid spacing in x-direction, do the following steps in "Grid in x-direction" frame: 

- Choose "Constant grid interval" check box 

- Type 50 in the "No. of grid intervals" edit box, the base of the tank is divided into 50 equal 

elements, each of 0.2 [m] 

 

 
Figure 9.10 "Net of Base" Form 

Click "Finish" button, the FE-Net of the tank wall and a sector from the base appears in Figure 9.11. 
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Figure 9.11 Generated FE-Net  

After finishing the generation of the FE-Net, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 9.11 to save the data of the FE-Net 

- Choose "Close" command from "File" menu in Figure 9.11 to close the "FE-Net" window 

and return to ELPLA main window 
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4.4 Shell properties 

To define the tank properties, choose "Shell Properties" command from “Data” Tab. The following 

window in Figure 9.12 appears with default shell properties. The data of shell properties for the 

current example, which are required to be defined, are element groups, group regions, unit weight of 

the tank, and the filled material properties. 

 

 
Figure 9.12 "Shell Properties" Window 

Choose "Element groups" command from "In table" menu. The following list box in Figure 9.13 appears. 

In this list box, define E-Modulus, Poisson’s ratio and slab thickness for both the tank wall  

and the tank base, as they differ in thickness. Then click "OK" button. 
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Figure 9.13 "Defining element groups" list box 

Defining the slab thickness for materials on the net may be carried out either graphically or numerically 

(in a table). In the current example, the user will define the slab thickness on the net graphically. 

 

To define the slab thickness for the tank base  

 

- Choose "Select Elements" command from "Graphically" menu in the window  

of Figure 9.12.  

- When "Select Elements" command is chosen, the cursor will change from an arrow to  

a cross hair. A group of elements can be selected by holding the left mouse button down  

at the corner of the region. Then, drag the mouse until a rectangle encompasses the required 

group of elements. When the left mouse button is released, all elements in the rectangle are selected 

- Select the elements that include the tank base as shown in Figure 9.14 

- Choose "Elements Groups" command from "Graphically" menu in the window  

of Figure 9.12, "Group Regions" dialog box Figure 9.15 appears 

- Define the "Group No." as type "2", while "Group No." of the tank wall elements will be  

as type "1", where type "1" is the default "Group No.", then click "OK" button 
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Figure 9.14 Selecting the nodes that include the tank base 

 
Figure 9.15 "Group Regions" dialog box 

To enter the unit weight of the tank, choose "Unit weight" command from "Shell Properties" menu 

in Figure 9.12. The following dialog box in Figure 9.16 with a default unit weight of 25 [kN/m3] appears, 

type 24 in the "Unit Weight" edit box, then click "OK" button. 

 

 
Figure 9.16 "Unit weight" dialog box 
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To define the filled material properties of the shell, choose "Filled material type/Element size" 

command from "Shell Properties" menu in Figure 9.12. The following form in Figure 9.17 appears. 

 

 
Figure 9.17 "Liquid Properties/Element size" dialog box 

To define the filled material properties of the tank: 

 

- Select the "Liquid container" option 

- Type 10 in the "Height of the liquid" edit box 

- Type 10.19 in the "Unit weight of the liquid" edit box 

 

To define the element size of the ring wall: 

 

- Check the "Constant element sizes in z-direction" check box 

- Type 1 in the "Element size in each shell segment" edit box. The element size is chosen  

to be 1 [m] larger than the segment size in order to ignore further subdivision of the 

segments into smaller elements. In some cases, it is necessary to divide the segment into 

smaller elements in order to make the analysis more precise. Nevertheless, the final results 

of the internal forces appear only at nodes of segments 

- Click "OK" button 
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Figure 9.18 "Shell Properties" window after defining the shell data 

After entering the shell properties, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 9.18 to save the shell properties 

- Choose "Close" command from "File" menu in Figure 9.18 to close the "Shell 

properties" window and return to ELPLA main window 
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4.5 Soil properties 

To define the soil properties, choose "Soil Properties" command from “Data” Tab. The following 

"Soil Properties" form in Figure 9.19 appears, the soil properties are defined by Modulus of 

Elasticity "E", and is supposed to have the following parameters: 

 

Modulus of Elasticity of the soil E  = 20000  [kN/m2] 

Unit weight of the soil GAM  = 18  [kN/m3] 

Angle of internal friction 

Cohesion of the soil 

Poisson's ratio of the soil medium   

FHI = 30   [˚] 

c  = 0  [kN/m2] 

νs = 0.2       [-] 

 

Other data in the example are not required, the user can use the default values. 

 

 
Figure 9.19 "Soil Properties" form 

After defining the soil properties, click "Save" button. 
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4.6 Loads 

To define the loads, choose "Loads" command from “Data” Tab. The following window  
in Figure 9.20 appears. In ELPLA, entering loads may be carried out either numerically (in a table) 
or graphically using the commands of "Loads" Tab in Figure 9.20. In this example, there is not 
applied load, as the vertical load has been already defined by the unit weight of the tank,  
while the hydrostatic pressure on the tank wall is defined by the unit weight of water. 
 

 
Figure 9.20 "Loads" Window 

After finishing the definition of load data, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 9.20 to save the load data 

- Choose "Close" command from "File" menu in Figure 9.20 to close the "Loads" window 

and return to ELPLA main window 

 

Creating the project of the tank is now complete. It is time to analyze this project. In the next 

section, you will learn how to use ELPLA for analyzing projects. 

 

 

 

 

 

 

 

 

 



Example 9  

 

 

   -9.21- 

5 Carrying out the calculations 

To analyze the problem, switch to "Solver" Tab, Figure 9.21. 

 

 
Figure 9.21 "Solver" Tab 

ELPLA will active the "Individual Calculations" list, which contains commands of all calculations. 

Commands of calculation depend on the used calculation method in the analysis. For this project, 

the items that are required to be calculated are: 

 

- Assembling the load vector 

- Determining flexibility coefficients of the soil  

- Assembling the slab stiffness matrix 

- Iteration process 

- Determining deformation, internal forces, contact pressures 

 

These calculation items can be carried out individually or in one time 

Carrying out all computations 

To carry out all computations in one time 

 

- Choose "Computation of all" command from "Solver" Tab Window. The following 

"Iteration parameters" option box in Figure 9.22 appears 

For this example, choose an accuracy of 0.0001 [m] to end the iteration process 

- Click "OK" button 

 

 
Figure 9.22 "Iteration parameters" option box 

The progress of all computations according to the defined method will be carried out automatically 

with displaying Information through menus and messages. 
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Analysis progress 

 

Analysis progress menu in Figure 9.23 appears in which various phases of calculation  

are progressively reported as the program analyzes the problem. In addition, a status bar down  

of the "Solver" Tab window displays Information about the progress of calculation. 

 

 
Figure 9.23 Analysis progress menu 

"Check of convergence" message Figure 9.24 appears showing that no convergence is reached 

 at the last step, click "Ok" button. 

 

 
Figure 9.24 "Check of convergence" message 

Click "Stop" button in Figure 9.25, to stop the iteration process as no convergence has reached. 
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Figure 9.25 "Iteration process" list box 

 

Check of the solution 

 

Once the analysis is carried out, a check menu of the solution appears, Figure 9.26. This menu 

compares between the values of actions and reactions. Through this comparative examination,  

the user can assess the calculation accuracy.  

 

 
Figure 9.26 Menu "Check of the solution" 

 

Click "OK" button to finish analyzing the problem. 
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6 Viewing data and results 

ELPLA can display and print a wide variety of results in graphics, diagrams or tables through  

the "Results" Tab. To view the data and results of a problem that has already been defined  

and analyzed graphically, switch to "Results" Tab (Figure 9.27). 

 

 
Figure 9.27 "Results" Tab 

The "Result" Tab contains the commands of drawing. These commands depend on the used 

calculation method in the analysis. For the current example, the commands for presenting the data 

and results are: 

 

- Data in the plan 

- Rotational shell results 

- Sections in shell base 

- Sections in shell wall 

- Display tables of data 

- Display tables of results 

 

To view the radial forces in the shell wall  

 

- Choose "Sections in shell wall" command from "Section" menu. The following option box 

in Figure 9.30 appears 

- In the "Sections in shell wall" option box, select "Radial forces Nr" as an example  

for the results to be displayed 

- Click "OK" button 

 

The Results are now displayed as shown in Figure 9.29. 
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Figure 9.28 "Sections in shell wall" option box 

 
Figure 9.29 Radial forces in shell wall 
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To view the meridional moments in the shell base  

 

- Choose "Sections in shell base" command from "Section" menu. The following option box 

in Figure 9.30 appears 

- In the "Sections in shell base" option box, select "Meridional moments My" as an example  

for the results to be displayed 

- Click "OK" button 

 

The Results are now displayed as shown in Figure 9.31. 

 

 
Figure 9.30 "Sections in shell base" option box 

 
Figure 9.31 Meridional moments in shell base 
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To view element groups of the tank  

 

- Choose "Element groups" from "In Plan" command in "Data" menu. The following option 

box in Figure 9.32 appears 

- In the "Data – In Plan" option box, select "Element groups" as an example for the results  

to be displayed 

- Click "OK" button 

 

 
Figure 9.32 "Data – In Plan" option box 

To view the meridional moments on the FE-Net and any other data 

 

- From "Options" menu in the "Graphic" tab, choose "View Grouping" command.  

The "View Grouping" check group box in Figure 9.33 appears 

- In this check group box, check "Meridional moments My" check box 

- The user can choose any other data to be displayed 

- Click "OK" button 

 

 
Figure 9.33 "View Grouping" check group box 
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Figure 9.34 Element groups of the tank with the meridional moments 

 

 

 

 

 


