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1 Description of the problem 

An example of an axi-symmetrically circular cylindrical tank resting on elastic foundation  

using Winkler’s model is selected to illustrate some features of ELPLA for analyzing shell elements. 

2 Tank geometry and properties 

A circular cylindrical tank of an inner diameter of d = 13 [m] and a height of H = 3.5 [m]  

is considered as shown in Figure 6.1. Thickness of the tank wall is t = 0.175 [m]. The tank is filled 

with water. The soil under the base of the tank is represented by isolated springs of stiffness ks, 

which represent modulus of subgrade reaction. The tank material, unit weight of the water  

and the modulus of subgrade reaction are listed in Table 6.1.  

 

 
Figure 6.1 Circular cylindrical tank resting on isolated springs with dimensions 

Table 6.1 Tank material, water unit weight and modulus of subgrade reaction 

Modulus of Elasticity of the tank material   Ec = 2×107 [kN/ m2] 

Poisson's ratio of the tank material     νc = 0.2             [-] 

Unit weight of the tank material                           γc = 25  [kN/ m3] 

Unit weight of the water     γw  = 10  [kN/ m3] 

Modulus of subgrade reaction    ks  = 100 000 [kN/ m3] 
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νc = 0.20    [-] 

γc = 25       [kN/ m3] 

γw = 10       [kN/ m3] 
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3 Numerical Analysis 

In order to analyze the tank, the height of the tank is divided into 35 equal segments, each of 0.10 [m],  

as shown in Figure 6.2. The base of the tank is divided into 50 equal segments, each of 0.13 [m].  

 

 
Figure 6.2 Finite element mesh of the tank 

4 Creating the project 

In this section, the user will learn how to create a project for analyzing an axi-symmetrically circular 

cylindrical tank resting on elastic foundation using Winkler’s model. The project will be processed 

gradually to show the possibilities and abilities of the program. To enter the data of the example, 

follow the instructions and steps in the next paragraphs. 

4.1 Calculation method 

Choose "New Project" command from the "File" menu. The following "Calculation Methods" 

wizard appears, Figure 6.3. This wizard will help the user to define the analysis type and the 

calculation method of the problem through a series of Forms. The first Form of "Calculation 

Methods" wizard is the "Analysis Type" Form (Figure 6.3). 
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Figure 6.3 "Analysis Type" Form 

In the "Analysis Type" Form in Figure 6.3, define the analysis type of the problem. As the analysis 

type is a circular cylindrical tank problem, select "Analysis of rotational Shell" button, and check 

"Shell with a raft foundation" option, then click "Next" button to go to the next Form. After clicking 

"Next" button, the "Calculation Methods" Form appears, Figure 6.4. 
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To define the calculation method: 

 

- Select the calculation method "2/3 Constant/ Variable Modulus of Subgrade Reaction" 

- To determine the modulus of subgrade reaction, select "Modulus is defined by the user"  

- Click "Next" button to go to the next Form 

 

 
Figure 6.4 "Calculation Method" Form 

The last Form in the wizard is the "Options" Form, Figure 6.5. In this Form, ELPLA displays some 

available options corresponding to the chosen numerical model, which differ from model to other. 

Since no option will be considered in the analysis, click the "Save" button. 
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Figure 6.5 "Options" Form 

After clicking "Save" button, the "Save as" dialog box appears, Figure 6.6. In this dialog box 

type a file name for the current project in "File name" edit box. For example,  

type "Tank on Winkler's medium". ELPLA will use automatically this file name in all reading  

and writing processes. 
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Figure 6.6 "Save as" dialog box 

ELPLA will activate the “Data” Tab. In addition, the file name of the current project  

[Tank on Winkler's medium] will be displayed instead of the word [Untitled] in the ELPLA title bar. 
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4.2 Project identification 

The user can enter three lines of texts to describe the problem and the basic information about the task. 

These texts are required only for printing and plotting the data and results. Project identification 

does not play any role in the analysis. The three lines are optionally and maybe not completely 

entered. To identify the project, choose "Project Identification" command from the “Data” Tab. 

The dialog box in Figure 6.7 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box:  

"Analysis of a tank resting on Winkler's medium" 

- Type the date of the project in the "Date" edit box 

- Type the word "Axisymmetric Structures and Tanks" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 6.7 "Project Identification" dialog box 

4.3 FE-Net data 

For the given problem, the tank has an inner diameter of d = 13 [m] and a height of H = 3.5 [m].  

the tank height is divided into 35 equal segments, each of 0.10 [m], where the base of the tank  

is divided into 50 equal segments, each of 0.13 [m]. To define the FE-Net for this tank,  

choose "FE-Net Data" command from the “Data” Tab. "Analysis of rotational shell" wizard appears 

as shown in Figure 6.8. This wizard will guide you through the steps required to generate a FE-Net.  

 

The first Form of the wizard is the "Shell type" Form, which contains a group of templates of 

different shapes of nets. These net templates are used to generate standard nets. 
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Figure 6.8 "Analysis of rotational shell" wizard with "Shell type" Form 

To generate the FE-Net 

 

- In the "Shell type" options choose "Cylindrical shell" button 

- Type 3.5 in the "Height" edit box  

- Type 6.5 in the "Radius" edit box  

- Type 35 in the "Number of segments" edit box 

- Click "Next" button to go to the next Form 

 

After clicking "Next" in "Analysis of rotational shell" wizard, the following "Cylindrical shell" 

Form appears Figure 6.9, ELPLA divides the height of the tank into 35 equal segments,  

the user can edit the data of the segments individually by using "Modify" button, or all of them  

by using "In Table" button, if it is necessary. 
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Figure 6.9 "Cylindrical shell" Form 

After clicking "Next" in "Analysis of rotational shell" wizard, the following "Net of Base" Form 

appears Figure 6.10. 
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To edit the grid spacing in x-direction, do the following steps in "Grid in x-direction" frame: 

- Choose "Constant grid interval" check box  

- Type 50 in the "No. of grid intervals" edit box 

 

 
Figure 6.10 "Net of Base" Form 

Click "Finish" button, the FE-Net of the tank wall and a sector from the base appear in Figure 6.11 
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Figure 6.11 Generated FE-Net  

After finishing the generation of the FE-Net, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 6.11 to save the data of the FE-Net 

- Choose "Close" command from "File" menu in Figure 6.11 to close the "FE-Net" window 

and return to ELPLA main window 
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4.4 Shell properties 

To define the tank properties, choose "Shell Properties" command from “Data” Tab. The following 

window in Figure 6.12 appears with default shell properties. The data of shell properties for the 

current example, which are required to be defined, are element groups, unit weight of the tank,  

and filled material properties. 

 

 
Figure 6.12 "Shell Properties" Window 

Choose "Element groups" command from "In table" menu. The following list box in Figure 6.13 appears. 

In this list box, enter E-Modulus, Poisson’s ratio and slab thickness. Then click "OK" button. 
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Figure 6.13 "Defining element groups" list box 

To enter the unit weight of the tank, choose "Unit weight" command from "Shell Properties" menu 

in Figure 6.12. The following dialog box in Figure 6.14 with a default unit weight of 25 [kN/m3] appears, 

click "OK" button. 

 

 
Figure 6.14 "Unit weight" dialog box 
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To define the liquid properties of the shell, choose "Filled material type/Element size" command 

from "Shell Properties" menu in Figure 6.12. The following form in Figure 6.15 appears. 

 

To define the liquid properties of the tank: 

 

- Select the "Liquid container" option 

- Type 3.5 in the "Height of the liquid" edit box 

- Type 10 in the "Unit weight of the liquid" edit box 

 

To define the element size of the tank: 

 

- Check the "Constant element sizes in z-direction" check box 

- Type 1 in the "Element size in each shell segment" edit box. The element size is chosen  

to be 1 [m] larger than the segment size in order to ignore further subdivision of the 

segments into smaller elements. In some cases, it is necessary to divide the segment into 

smaller elements in order to make the analysis more precise. Nevertheless, the final results 

of the internal forces appear only at nodes of segments 

- Click "OK" button 

 

 
Figure 6.15 "Liquid properties/Element size" Form 

After entering the shell properties, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 6.12 to save the shell properties 

- Choose "Close" command from "File" menu in Figure 6.12 to close the "Shell properties" 

window and return to ELPLA main window 
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4.5 Soil Properties 

To define the soil properties, choose "Soil Properties" command from “Data” Tab. The following 

"Soil Properties" form in Figure 6.16 appears, enter the modulus of subgrade reaction of the soil and  

the ground water depth under the ground surface. Other data for this example is not required. 

 

Soil data 

Modulus of subgrade reaction    ks  = 100 000 [kN/ m3] 

Ground water depth under the surface   Gw  = 1  [m] 

 

 
Figure 6.16 "Soil Properties" Form 
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4.6 Loads 

To define the loads, choose "Loads" command from “Data” Tab. The following window  
in Figure 6.17 appears. In ELPLA, entering loads may be carried out either numerically (in a table) 
or graphically using the commands of "Loads" tab in Figure 6.17. In this example, there is not 
applied load, as the vertical load has been already defined by the unit weight of the tank,  
while the hydrostatic pressure on the tank wall is defined by the unit weight of water. 
 

 
Figure 6.17 "Loads" Window 

After finishing the definition of load data, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 6.17 to save the load data 

- Choose "Close" command from "File" menu in Figure 6.17 to close the "Loads" window 

and return to ELPLA main window 

 

Creating the project of the tank is now complete. It is time to analyze this project. In the next 

section, you will learn how to use ELPLA for analyzing projects. 
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5 Carrying out the calculations 

To analyze the problem, switch to "Solver" Tab, Figure 6.18. 

 

 
Figure 6.18 "Solver" Tab 

ELPLA will active the "Individual Calculations" list, which contains commands of all calculations. 

Commands of calculation depend on the used calculation method in the analysis. For this project, 

the items that are required to be calculated are: 

 

- Assembling the load vector 

- Determining the modulus of subgrade reaction 

- Assembling the slab stiffness matrix 

- Solving the system of linear equations (band matrix) 

- Determining deformation, internal forces, contact pressures 

 

These calculation items can be carried out individually or in one time 

 

To carry out all computations in one time 

 

- Choose "Computation of all" command from "Solver" Tab Window.  

 

The progress of all computations according to the defined method will be carried out automatically 

with displaying Information through menus and messages. 

 

Analysis progress 

 

Analysis progress menu in Figure 6.19 appears in which various phases of calculation are 

progressively reported as the program analyzes the problem. In addition, a status bar down of the 

"Solver" Tab window displays Information about the progress of calculation. 

 

 
Figure 6.19 Analysis progress menu 
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Check of the solution 

 

Once the analysis is carried out, a check menu of the solution appears, Figure 6.20. This menu 

compares between the values of actions and reactions. Through this comparative examination,  

the user can assess the calculation accuracy.  

 

 
Figure 6.20 Menu "Check of the solution" 

Click "OK" button to finish analyzing the problem. 
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6 Viewing data and results 

ELPLA can display and print a wide variety of results in graphics, diagrams or tables through the 

"Results" Tab. 

 

To view the data and results of a problem that has already been defined and analyzed graphically, 

switch to "Results" Tab (Figure 6.21).  

 

 
Figure 6.21 "Results" Tab 

The "Results" Tab contains the commands of drawing. These commands depend on the used 

calculation method in the analysis. For the current example, the commands for presenting the data 

and results are: 

 

- Data in the plan 

- Rotational shell results 

- Sections in shell wall 

- Sections in shell base 

- Display tables of data 

- Display tables of results 

 

To view the radial forces in the shell wall  

 

- Choose "Sections in shell wall" command from "Section" menu. The following option box 

in Figure 6.22 appears 

- In the "Sections in shell wall" option box, select "Radial forces Nr" as an example for the 

results to be displayed 

- Click "OK" button 

 

The Results are now displayed as shown in Figure 6.23. 

 

 
Figure 6.22 "Sections in shell wall" option box 
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Figure 6.23 Radial forces in shell wall 

To view the meridional moments on the shell wall  

 

- From "Rotational shell results" command in the "Results" menu, choose "In Plan" command, 

the following option box in Figure 6.24 appears 

- In the "Distribution of Internal Forces" option box, select "Meridional moments My"  

as an example for the results to be displayed 

- Click "OK" button 

 

The Results are now displayed as shown in Figure 6.23. 

 

 
Figure 6.24 "Distribution of Internal Forces" option box 
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Figure 6.25 Meridional moments on the shell wall 

 

 


