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1 Description of the problem 

An example of an axi-symmetrically circular cylindrical tank covered with a spherical dome roof is 

selected illustrate some features of ELPLA for analyzing shell elements. 

2 Tank geometry and properties 

Figure 5.1 shows half of an axial section of a large-diameter reinforced concrete circular cylindrical 

tank covered with a dome roof. The wall connection with the roof is monolithic, while the end of 

the wall is fixed at the base. Details concerning the geometry of the structure are  

shown in Figure 5.1. The elastic properties of the tank material are shown in Table 5.1.  

Only the self-weight is considered in this analysis. 

 

 
Figure 5.1 Radial section through the tank 

Table 5.1 Tank material 

Modulus of Elasticity of the tank material   Ec = 3×107 [kN/ m2] 

Poisson's ratio of the tank material    νc = 0.16             [-] 

Unit weight of the tank material                                      γc = 25  [kN/ m3] 
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3 Numerical Analysis 

In order to analyze the tank, the height of the wall is divided into 50 equal elements,  

each of 0.20 [m], while the roof shell (dome) is divided into 40 equal arcs each of 0.75 [°]  

as shown in Figure 5.2.  

 

 
Figure 5.2 Finite element mesh of the tank 

4 Creating the project 

In this section, the user will learn how to create a project for analyzing an axi-symmetrically circular 

cylindrical tank covered with a spherical dome roof. The project will be processed gradually  

to show the possibilities and abilities of the program. To enter the data of the example,  

follow the instructions and steps in the next paragraphs. 

4.1 Calculation method 

Choose "New Project" command from the "File" menu. The following "Calculation Methods" 

wizard appears, Figure 5.3. This wizard will help the user to define the analysis type and the 

calculation method of the problem through a series of Forms. The first Form of  

"Calculation Methods" wizard is the "Analysis Type" Form (Figure 5.3). 
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Figure 5.3 "Analysis Type" Form 

In the "Analysis Type" Form in Figure 5.3, define the analysis type of the problem.  

As the analysis type is a circular cylindrical covered with a spherical dome roof problem,  

select "Analysis of rotational Shell" button, and check "Shell with an opening base" option,  

then click "Next" button to go to the next Form.  
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The last Form in the wizard is the "Options" Form, Figure 5.4. In this Form, ELPLA displays some 

available options corresponding to the chosen numerical model, which differ from model to other. 

Select "Supports/ Boundary Conditions", then click the "Save" button. 

 

 
Figure 5.4 "Options" Form 

After clicking "Save" button, the "Save as" dialog box appears, Figure 5.5. In this dialog box 

type a file name for the current project in "File name" edit box. For example, type "Tank with 

covered roof". ELPLA will use automatically this file name in all reading and writing processes. 
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Figure 5.5 "Save as" dialog box 

ELPLA will activate the “Data” Tab. In addition, the file name of the current project [Tank with 

covered roof] will be displayed instead of the word [Untitled] in the ELPLA title bar. 
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4.2 Project identification 

The user can enter three lines of texts to describe the problem and the basic information about the task. 

These texts are required only for printing and plotting the data and results. Project identification 

does not play any role in the analysis. The three lines are optionally and maybe not completely 

entered. To identify the project, choose "Project Identification" command from the “Data” Tab. 

The dialog box in Figure 5.6 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box:  

"Analysis of a tank covered with a spherical dome" 

- Type the date of the project in the "Date" edit box 

- Type the word "Axisymmetric Structures and Tanks" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 5.6 "Project Identification" dialog box 
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4.3 FE-Net data 

For the given problem, a tank covered with a dome roof has a lower radius of a = 15 [m],  

a clear height of Hw = 10 [m], and the radius of the spherical roof is R = 30.1 [m]. the height of the wall 

is divided into 50 equal elements, each of 0.20 [m], while the roof shell (dome) of 30[°] is divided 

into 40 equal arcs each of 0.75 [°] (gives also 40 elements). To define the FE-Net for this tank, 

choose "FE-Net Data" command from the “Data” Tab. "Analysis of rotational shell" wizard appears  

as shown in Figure 5.7. This wizard will guide you through the steps required to generate a FE-Net.  

 

The first Form of the wizard is the "Shell type" Form, which contains a group of templates of 

different shapes of nets. These net templates are used to generate standard nets. 

 

 
Figure 5.7 "Analysis of rotational shell" wizard with "Shell type" Form 
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To generate the FE-Net of the tank: 

 

- In the "Shell type" options choose "Irregular shell" button 

To define the base of the tank: 

• Type 15 in the "Tank base radius Rb" edit box 

  To define the height of the tank: 

• Choose "Linear segments" option 

• Type 10 in the "height Hw" edit box  

• Type 15 in the "Upper radius Ro" edit box, as the upper radius is the same as  

the base radius 

• Type 50 in the "Number of segments Ns" edit box 

To define the roof of the tank: 

• Check the "Shell with covered roof" check box 

• Choose "Spherical roof" option 

• Type 30.10 in the "Radius of the spherical roof" edit box  

• Type 30 in the "Angle of the spherical roof" edit box 

• Type 40 in the "Number of roof segments" edit box 

- Click "Next" button to go to the next Form 

 

After clicking "Next" in "Analysis of rotational shell" wizard, the following "Irregular shell" Form 

appears Figure 5.8, ELPLA divides the height of the wall into 50 equal elements, each of 0.20 [m], 

while the roof shell (dome) is divided into 40 equal arcs each of 0.75 [°], the user can edit the data 

of the segments individually by using "Modify" button, or all of them by using "In Table" button,  

if it is necessary. 
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Figure 5.8 "Irregular shell" Form 

Click "Finish" in "Analysis of rotational shell" wizard, to generate the FE-Net.  

The generated FE-Net appears Figure 5.9. 
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Figure 5.9 Generated FE-Net  

After finishing the generation of the FE-Net, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 5.9 to save the data of the FE-Net 

- Choose "Close" command from "File" menu in Figure 5.9 to close the "FE-Net" window and 

return to ELPLA main window 
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4.4 Shell properties 

To define the tank properties, choose "Shell Properties" command from “Data” Tab. The following 

window in Figure 5.10 appears with default shell properties. The data of shell properties for the 

current example, which are required to be defined, are element groups, group regions, unit weight  

of the tank, and filled material properties. 

 

 
Figure 5.10 "Shell Properties" Window 

Choose "Element groups" command from "In table" menu. The following list box in Figure 5.11 appears. 

In this list box, define E-Modulus, Poisson’s ratio and slab thickness for both the tank wall  

and the tank roof as they differ in thickness. Then click "OK" button. 
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Figure 5.11 "Defining element groups" list box 

Defining the slab thickness for materials on the net may be carried out either graphically or numerically 

(in a table). In the current example, the user will define the slab thickness on the net graphically. 

 

To define the slab thickness for the tank roof  

 

- Choose "Select Elements" command from "Graphically" menu in the window  

of Figure 5.10.  

- When "Select Elements" command is chosen, the cursor will change from an arrow to  

a cross hair. A group of elements can be selected by holding the left mouse button down at 

the corner of the region. Then, drag the mouse until a rectangle encompasses the required group 

of elements. When the left mouse button is released, all elements in the rectangle are selected 

- Select the elements that include the tank roof as Figure 5.12 

- Choose "Elements Groups" command from "Graphically" menu in the window  

of Figure 5.10, "Group Regions" dialog box Figure 5.13 appears 

- Define the "Group No." as type "2", while "Group No." of the wall elements will be as  

type "1", where type "1" is the default "Group No." then click "OK" button 
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Figure 5.12 Selecting the nodes that include the tank roof 

 

 
Figure 5.13 "Group Regions" dialog box 

To enter the unit weight of the tank, choose "Unit weight" command from "Shell Properties" menu 

in Figure 5.10. The following dialog box in Figure 5.14 with a default unit weight of 25 [kN/m3] appears, 

click "OK" button. 

 

 
Figure 5.14 "Unit weight" dialog box 
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To define the element size of the shell, choose "Filled material type/Element size" command from 

"Shell Properties" menu in Figure 5.10. The following form in Figure 5.15 appears. 

 

To define the element size of the ring wall: 

 

- Select "Empty container" option 

- Check the "Constant element sizes in z-direction" check box 

- Type 1 in the "Element size in each shell segment" edit box. The element size is chosen  

to be 1 [m] larger than the segment size in order to ignore further subdivision of the 

segments into smaller elements. In some cases, it is necessary to divide the segment into 

smaller elements in order to make the analysis more precise. Nevertheless, the final results 

of the internal forces appear only at nodes of segments 

- Click "OK" button 

 

 
Figure 5.15 "Liquid Properties/Element size" dialog box 
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Figure 5.16 "Shell Properties" window after defining the shell data 

After entering the tank properties, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 5.16 to save the shell properties 

- Choose "Close" command from "File" menu in Figure 5.16 to close the "Shell properties" 

window and return to ELPLA main window 
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4.5 Supports/ boundary conditions 

To define the support, choose "Supports/ Boundary Conditions" command from “Data” Tab.  

The following window in Figure 5.17 appears. 

 

 
Figure 5.17 "Supports/ Boundary Conditions" Window 

To define the support on the net: 

 

- Choose "Select Nodes" command from "Graphically" menu in Figure 5.17. When "Select 

Nodes" command is chosen, the cursor will change from an arrow to a cross hair 

- Click the left mouse button on the node that has the fixed support as shown in Figure 5.18 

- After selecting the node, choose "Add Supports/ Boundary Conditions" command  

from "Graphically" menu (Figure 5.17). The "Supports/ Boundary Conditions" dialog box  

in Figure 5.19 appears. 
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Figure 5.18 Selection of the node that has the fixed support 
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In this dialog box 

 

- Type 0 in the "Displacement u" edit box to define the horizontal fixed support 

- Type 0 in the "Displacement w" edit box to define the vertical fixed support 

- Type 0 in the "Rotation Theta" edit box to define the rotational fixed support 

- Click "OK" button 

 

 
Figure 5.19 "Supports/ Boundary Conditions" dialog box 
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Figure 5.20 "Supports/ Boundary Conditions" window after defining the support 

After defining the supports, do the following two steps 

 

- Choose "Save " command from "File" menu in Figure 5.20 to save the data of supports 

- Choose "Close" command from "File" menu in Figure 5.20 to close the "Supports/ Boundary 

conditions" window and return to the main window 
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4.6 Loads 

To define the loads, choose "Loads" command from “Data” Tab. The following window  
in Figure 5.21 appears. In ELPLA, entering loads may be carried out either numerically (in a table) 
or graphically using the commands of "Loads" Tab in Figure 5.21. In this example, there is not 
applied load, as the vertical load has been already defined by the unit weight of the tank. 
 

 
Figure 5.21 "Loads" Window 

After finishing the definition of load data, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 5.21 to save the load data 

- Choose "Close" command from "File" menu in Figure 5.21 to close the "Loads" window 

and return to ELPLA main window 

 

Creating the project of the tank is now complete. It is time to analyze this project.  

In the next section, you will learn how to use ELPLA for analyzing projects. 
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5 Carrying out the calculations 

To analyze the problem, switch to "Solver" Tab, Figure 5.22. 

 

 
Figure 5.22 "Solver" Tab 

ELPLA will active the "Individual Calculations" list, which contains commands of all calculations. 

Commands of calculation depend on the used calculation method in the analysis. For this project, 

the items that are required to be calculated are: 

 

- Assembling the load vector 

- Assembling the slab stiffness matrix 

- Solving the system of linear equations (band matrix) 

- Determining deformation, internal forces, contact pressures 

 

These calculation items can be carried out individually or in one time 

 

To carry out all computations in one time 

 

- Choose "Computation of all" command from "Solver" Tab window.  

 

The progress of all computations according to the defined method will be carried out automatically 

with displaying Information through menus and messages. 

 

Analysis progress 

 

Analysis progress menu in Figure 5.23 appears in which various phases of calculation are 

progressively reported as the program analyzes the problem. In addition, a status bar down of the 

"Solver" Tab window displays Information about the progress of calculation. 

 

 
Figure 5.23 Analysis progress menu 
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Check of the solution 

 

Once the analysis is carried out, a check menu of the solution appears, Figure 5.24. This menu 

compares between the values of actions and reactions. Through this comparative examination,  

the user can assess the calculation accuracy.  

 

 
Figure 5.24 Menu "Check of the solution" 

Click "OK" button to finish analyzing the problem. 
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6 Viewing data and results 

ELPLA can display and print a wide variety of results in graphics, diagrams or tables through  

the "Results" Tab. To view the data and results of a problem that has already been defined  

and analyzed graphically, switch to "Results" Tab (Figure 5.25).  

 

 
Figure 5.25 "Results" Tab 

The "Result" Tab contains the commands of drawing. These commands depend on the used 

calculation method in the analysis. For the current example, the commands for presenting the data 

and results are: 

 

- Data in the plan 

- Rotational shell results 

- Support Reactions 

- Sections in shell wall 

- Display tables of data 

- Display tables of results 

 

To view element groups of the tank  

 

- Choose "Element groups" from "In Plan" command in "Data" menu. The following option 

box in Figure 5.25 appears 

- In the "Data – In Plan" option box, select "Element groups" as an example for the results  

to be displayed 

- Click "OK" button 

 

 
Figure 5.26 "Data – In Plan" option box 
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To view the supports / boundary conditions on the FE-Net and any other data 

 

- From "Options" menu in the "Graphic" tab, choose "View Grouping" command.  

The "View Grouping" check group box in Figure 5.27 appears 

- In this check group box, check "Supports Reactions Rv", "Supports Reactions Rh", "Supports 

Reactions Rm", "Supports /Boundary Conditions", "Meridional moments My" check boxes  

- The user can choose any other data to be viewed 

- Click "OK" button 

 

 
Figure 5.27 "View Grouping" check group box 

 
Figure 5.28 Element groups of the tank 

 

 


