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1 Description of the problem 

An example of a reservoir with a variable wall thickness is selected to illustrate some features of 

ELPLA for analyzing shell elements. 

2 Geometry and properties 

A reservoir wall of a radius a = 100 [m] and a height H = 100.1 [m] is considered as shown  

in Figure 4.1. The wall of the reservoir has a variable thickness, at the base the thickness is h11 = 13.3 

[m], while at the top the thickness is h0 = 4 [m], thickness in between h [m] can be obtained from 

the following equation:  

 

where x is the distance from the top in [m]. 

 

 
Figure 4.1 reservoir wall with dimensions  

 

The reservoir wall is exposed to a hydrostatic water pressure and is fixed at the base. The wall 

material and unit weight of the water are listed in Table 4.1.  
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Table 4.1 Wall material and water unit weight  

Modulus of Elasticity of the reservoir wall material  Ec = 2.1×107 [kN/m2] 

Poisson's ratio of the reservoir wall material   νc = 0     [-] 

Unit weight of the water     γw  = 10     [kN/m3] 

3 Analysis of the reservoir wall 

In the analysis, the total height of the wall is divided into 11 segments with a constant length; each 

is (Figure 4.2): 
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Figure 4.2 Finite element mesh of the reservoir wall with wall thickness 
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4 Creating the project 

In this section, the user will learn how to create a project for analyzing cylindrical shells  

with variable wall thickness. The project will be processed gradually to show the possibilities and 

abilities of the program. To enter the data of the example, follow the instructions and steps  

in the next paragraphs. 

4.1 Calculation method 

Choose "New Project" command from the "File" menu. The following "Calculation Methods" 

wizard appears, Figure 4.3. This wizard will help the user to define the analysis type  

and the calculation method of the problem through a series of Forms. The first Form of "Calculation 

Methods" wizard is the "Analysis Type" Form (Figure 4.3). 

 

 
Figure 4.3 "Analysis Type" Form 

In the "Analysis Type" Form in Figure 4.3, define the analysis type of the problem. As the analysis 

type is a cylindrical shell with a variable wall thickness problem, select "Analysis of rotational 

Shell" button, and check "Shell with an opening base" option, then click "Next" button to go to the 

next Form.  
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The last Form in the wizard is the "Options" Form, Figure 4.4. In this Form, ELPLA displays some 

available options corresponding to the chosen numerical model, which differ from model to other. 

Select "Supports/ Boundary Conditions", then click the "Save" button. 

 

 
Figure 4.4 "Options" Form 

After clicking "Save" button, the "Save as" dialog box appears, Figure 4.5. In this dialog box 

type a file name for the current project in "File name" edit box. For example, type "Reservoir wall". 

ELPLA will use automatically this file name in all reading and writing processes. 
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Figure 4.5 "Save as" dialog box 

ELPLA will activate the “Data” Tab. In addition, the file name of the current project [Reservoir 

wall] will be displayed instead of the word [Untitled] in the ELPLA title bar. 
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4.2 Project identification 

The user can enter three lines of texts to describe the problem and the basic information about the task. 

These texts are required only for printing and plotting the data and results. Project identification 

does not play any role in the analysis. The three lines are optionally and maybe not completely 

entered. To identify the project, choose "Project Identification" command from the “Data” Tab. 

The dialog box in Figure 4.6 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box:  

"Analysis of a reservoir wall with a variable wall thickness" 

- Type the date of the project in the "Date" edit box 

- Type the word "Axisymmetric Structures and Tanks" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 4.6 "Project Identification" dialog box 

4.3 FE-Net data 

A reservoir wall of a radius a = 100 [m] and a height H = 100.1 [m] is considered as shown  

in Figure 4.1. The wall of the reservoir has a variable thickness, at the base the thickness is h11 = 13.3 [m], 

while at the top the thickness is h0 = 4 [m], the total height of the wall is divided into 11 segments 

with a constant length, each 9.10 [m]. To define the FE-Net for this shell, choose "FE-Net Data" 

command from the “Data” Tab. "Analysis of rotational shell" wizard appears as shown in Figure 4.7. 

This wizard will guide you through the steps required to generate a FE-Net.  

 

The first Form of the wizard is the "Shell type" Form, which contains a group of templates of 

different shapes of nets. These net templates are used to generate standard nets. 
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Figure 4.7 "Analysis of rotational shell" wizard with "Shell type" Form 

To generate the FE-Net 

 

- In the "Shell type" options choose "Cylindrical shell" button 

- Type 100.1 in the "Height" edit box,  

- Type 100 in the "Radius" edit box,  

- Type 11 in the "Number of segments" edit box 

- Click "Next" button to go to the next Form 

 

After clicking "Next" in "Analysis of rotational shell" wizard, the following "Cylindrical shell" 

Form appears, Figure 4.8. ELPLA divides the height of the reservoir wall into 11 equal segments,  

the user can edit the data of the segments individually by using "Modify" button, or all of them  

by using "In Table" button, if it is necessary. 

 



Analyzing Axisymmetric Structures and Tanks by ELPLA 

 
 

 -4.10- 

 
Figure 4.8 "Cylindrical shell" Form 

Click "Finish" button, the FE-Net appears in Figure 4.9 
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Figure 4.9 Generated FE-Net  

After finishing the generation of the FE-Net, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 4.9 to save the data of the FE-Net 

- Choose "Close" command from "File" menu in Figure 4.9 to close the "FE-Net" window and 

return to ELPLA main window 
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4.4 Shell properties 

To define the reservoir properties, choose "Shell Properties" command from “Data” Tab.  

The following window in Figure 4.10 appears with default shell properties. The data of reservoir 

properties for the current example, which are required to be defined, are element groups, group 

regions, unit weight of the reservoir and liquid properties. 

 

 
Figure 4.10 "Shell Properties" Window 

Choose "Element groups" command from "In table" menu. The following list box in Figure 4.11 appears. 

In this list box, enter E-Modulus, Poisson’s ratio and slab thicknesses of the segments as the following list. 

Then click "OK" button. 
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Figure 4.11 "Defining element groups" list box 
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Choose "Group Regions " command from "In table" menu. The following list box in Figure 4.12 appears. 

In this list box, edit the "Group No." value for each segment. Then click "OK" button. 

 

 
Figure 4.12 "Group Regions" list box 

To enter the unit weight of the reservoir, choose "Unit weight" command from "Shell Properties" 

menu in the window of Figure 4.10. The following dialog box in Figure 4.13 with a default unit 

weight of 25 [kN/m3] appears, type 0 in the "Unit weight" edit box to neglect the wall weight in the 

analysis, then click "OK" button. 

 

 
Figure 4.13 "Unit weight" dialog box 

 

 

 

 

 

 

 



Example 4  

 

 

   -4.15- 

To define the liquid properties of the reservoir, choose "Filled material type/Element size" command 

from "Shell Properties" menu in the window of Figure 4.10. The following form in Figure 4.14. 

 

To define the filled material properties of the reservoir wall: 

 

- Select the "Liquid container" check box, 

- Type 100.1 in the "Height of the liquid" edit box, 

- Type 9.81 in the "Unit weight of the liquid" edit box, 

 

To define the element size of the ring wall: 

 

- Check the "Constant element sizes in z-direction" check box, 

- Type 9.1 in the "Element size in each shell segment" edit box, 

- Click "OK" button 

 

 
Figure 4.14 "Liquid properties/Element size" Form 
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Figure 4.15 "Shell Properties" window after entering the data 

After entering the shell properties, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 4.15 to save the shell properties 

- Choose "Close" command from "File" menu in Figure 4.15 to close the "Shell 

properties" window and return to ELPLA main window 
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4.5 Supports/ boundary conditions 

To define the fixed support, choose "Supports/ Boundary Conditions" command from “Data” Tab.  

The following window in Figure 4.16 appears. 

 

 
Figure 4.16 "Supports/ Boundary Conditions" Window 

To define supports on the net: 

 

- Choose "Select Nodes" command from "Graphically" menu in Figure 4.16. When "Select 

Nodes" command is chosen, the cursor will change from an arrow to a cross hair 

- Click the left mouse button on the node that has the fixed support as shown in Figure 4.17 

- After selecting the node, choose "Add Supports/ Boundary Conditions" command  

from "Graphically" menu Figure 4.16. The "Supports/ Boundary Conditions" dialog box  

in Figure 4.18 appears. 
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Figure 4.17 Selection of node that has a fixed support 
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In this dialog box 

 

- Type 0 in the "Displacement u" edit box to define the horizontal fixed support 

- Type 0 in the "Displacement w" edit box to define the vertical fixed support 

- Type 0 in the "Rotation Theta" edit box to define the rotational fixed support 

- Click "OK" button 

 

 
Figure 4.18 "Supports/ Boundary Conditions" dialog box 
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Figure 4.19 Supports on the screen 

After entering supports, do the following two steps 

 

- Choose "Save " command from "File" menu in Figure 4.19 to save the data of supports 

- Choose "Close" command from "File" menu in Figure 4.19 to close the "Supports/ Boundary 

conditions" window and return to the main window 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Example 4  

 

 

   -4.21- 

4.6 Loads 

To define the loads, choose "Loads" command from “Data” Tab. The following window  
in Figure 4.20 appears. In ELPLA, entering loads may be carried out either numerically (in a table) 
or graphically using the commands of "Loads" Tab in Figure 4.20. In this example, there is not 
applied load, as the vertical load has been already defined by the unit weight of the reservoir wall 
material, while the hydrostatic pressure on the reservoir wall is defined by the unit weight of water. 
 

 
Figure 4.20 "Loads" Window 

After finishing the definition of load data, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 4.20 to save the load data 

- Choose "Close" command from "File" menu in Figure 4.20 to close the "Loads" window 

and return to ELPLA main window  

 

 

Creating the project is now complete. It is time to analyze this project. In the next section, you will 

learn how to use ELPLA for analyzing projects. 
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5 Carrying out the calculations 

To analyze the problem, switch to "Solver" Tab, Figure 4.21. 

 

 
Figure 4.21 "Solver" Tab 

ELPLA will active the "Individual Calculations" list, which contains commands of all calculations. 

Commands of calculation depend on the used calculation method in the analysis. For this project, 

the items that are required to be calculated are: 

 

- Assembling the load vector 

- Assembling the slab stiffness matrix 

- Solving the system of linear equations (band matrix) 

- Determining deformation, internal forces, contact pressures 

 

These calculation items can be carried out individually or in one time 

 

To carry out all computations in one time 

 

- Choose "Computation of all" command from "Solver" Tab Window.  

 

The progress of all computations according to the defined method will be carried out automatically 

with displaying Information through menus and messages. 

 

Analysis progress 

 

Analysis progress menu in Figure 4.22 appears in which various phases of calculation are 

progressively reported as the program analyzes the problem. In addition, a status bar down of the 

"Solver" Tab window displays Information about the progress of calculation. 

 

 
Figure 4.22 Analysis progress menu 
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Check of the solution 

 

Once the analysis is carried out, a check menu of the solution appears, Figure 4.23. This menu 

compares between the values of actions and reactions. Through this comparative examination,  

the user can assess the calculation accuracy.  

 

 
Figure 4.23 Menu "Check of the solution" 

 

Click "OK" button to finish analyzing the problem. 
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6 Viewing data and results 

ELPLA can display and print a wide variety of results in graphics, diagrams or tables through  

the "Results" Tab. To view the data and results of a problem that has already been defined and 

analyzed graphically, switch to "Results" Tab (Figure 4.24).  

 

 
Figure 4.24 "Results" Tab 

The "Results" Tab contains the commands of drawing. These commands depend on the used 

calculation method in the analysis. For the current example, the commands for presenting the data 

and results are: 

 

- Data in the plan  

- Supports Reactions 

- Rotational shell Results 

- Sections in shell wall 

- Display tables of data 

- Display tables of results 

 

To view the meridional moments in the shell wall  

 

- Choose "Sections in shell wall" command from "Section" menu. The following option box 

in Figure 4.25 appears 

- In the "Sections in shell wall" option box, select "Meridional moments My" as an example 

for the results to be displayed 

- Click "OK" button 

 

The Results are now displayed as shown in Figure 4.26. 

 

 
Figure 4.25 "Sections in shell base" option box 
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Figure 4.26 Meridional moments in shell wall 
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To view element groups of the reservoir  

 

- Choose "Element groups" from "In Plan" command in "Data" menu. The following option 

box in Figure 4.27 appears 

- In the "Data – In Plan" option box, select "Element groups" as an example for the results  

to be displayed 

- Click "OK" button 

 

 
Figure 4.27 "Data – In Plan" option box 

To view the supports / boundary conditions on the FE-Net and any other data 
 

- From "Options" menu in the "Graphic" tab, choose "View Grouping" command.  

The "View Grouping" check group box in Figure 4.28 appears 

- In this check group box, check both "Supports Reactions RV", "Supports Reactions M" and 

"Supports /Boundary Conditions" check box  

- The user can choose any other data to be viewed 

- Click "OK" button 

 

 
Figure 4.28 "View Grouping" check group box 
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Figure 4.29 Element groups of the reservoir 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 


