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1 Description of the problem 

An example of a circular concrete silo is selected to illustrate some features of ELPLA for analyzing 

circular silos for storing bulk materials. 

2 Silo geometry and properties 

A circular concrete silo having a conical hopper at the bottom part and a conical roof at the upper 

part is considered. The main height of the silo is 8 [m] and its diameter is 4 [m]. The stored material 

is cement of a unit weight of 15.5 [kN/m3]. The angle of internal friction of cement is 25 [°] 

and the angle of wall friction is 25 [°]. The thickness of the roof and the wall is 0.28 [m], while the 

thickness of the hopper is 0.25 [m]. The conical hopper bottom slope is 45 [°], an opening at the 

bottom with diameter 0.5 [m] and hopper bottom height is 3 [m]. Table 13.1 shows the geometry of 

the silo with dimensions and support, while the silo shell material is listed in Table 13.1.  

 
Figure 13.1 Geometry of the silo with dimensions and support 

Table 13.1 Silo shell material  

Modulus of Elasticity of the shell material  Ec = 2.486×107    [kN/m2] 

Poisson's ratio of the shell material    νc = 0.2         [-] 

Unit weight of the shell material   γc = 23.563     [kN/m3] 

r=2 [m] 

H=14 

[m] 
pt=0.25[m] 

pt=0.28[m] 

3 [m] 

3 [m] 

0.25 [m] 

Conical hopper 

Conical roof 

Cylindrical shell 
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3 Pressure on the silo wall 

According to Janssen’s silo theory, the horizontal pressure Ph [kN/m2] on the silo wall  

at a depth h [m] below the free surface of the stored material is given by: 
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in which k is the ratio of horizontal to vertical pressures, usually assumed equal to Rankine’s 

coefficient of active earth pressure 

φsin 1

φsin -1

+
=k  

h   Depth from the material top to the calculation section, [m] 

k  Wall pressure coefficient, [-] 

φ  Angel of internal friction of the stored material, [°] 

γs  Unit weight of the stored material, [kN/m3] 

R=A/U  Hydraulic radius of the net horizontal cross section, [m] 

μ=tan δ  Friction coefficient between the silo wall and the stored material   

δ   Angle of the wall friction, [°]   

A=πD/4 Cross-sectional area of the silo, [m2] 

U=πD  Parameter of the silo, [m] 

D  Diameter of the silo, [m] 

 

Using the above relations and equations, the lateral pressure Ph on the main silo wall various depth 

is determined and presented in Table 13.2. 

Table 13.2 Lateral pressure Ph on the main silo wall  

Height from the top 

h [m] 

Lateral pressure on the silo wall 

Ph [kN/m2] 

0.5 3.00 

1.5 8.22 

2.5 12.53 

3.5 16.10 

4.5 19.06 

5.5 21.50 

6.5 23.53 

7.5 25.20 
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4 Numerical Analysis 

The wall of the silo is divided into three parts: 

1. The roof part where no lateral pressure is applied on it 

2. The main silo part where the lateral pressure ph is applied. 

3. The hopper part where no lateral pressure is applied on it 

 

In the analysis, these three parts are divided into 14 segments; each segment is 1.0 [m]. Then these 

segments are divided into a number of elements, each element is 0.2 [m]. Segment dimensions and 

number of segments are shown in Figure 13.2.  

  

 
Figure 13.2 Segment dimensions 

 

 

 

r=2 [m] 

H=14 [m] 
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5 Creating the project 

In this section, the user will learn how to create a project for analyzing a circular concrete silo.  

The project will be processed gradually to show the possibilities and abilities of the program.  

To enter the data of the example, follow the instructions and steps in the next paragraphs. 

5.1 Calculation method 

Choose "New Project" command from the "File" menu. The following "Calculation Methods" 

wizard appears, Figure 13.3. This wizard will help the user to define the analysis type  

and the calculation method of the problem through a series of forms. The first form of "Calculation 

Methods" wizard is the "Analysis Type" Form (Figure 13.3). 

 

 
Figure 13.3 "Analysis Type" Form 

In the "Analysis Type" Form in Figure 13.3, define the analysis type of the problem.  

As the analysis type is a circular concrete silo problem, select "Analysis of rotational Shell" button, 

and check "Shell with an opening base" option, then click "Next" button to go to the next Form. 

After clicking "Next" button, the "Options" Form appears, Figure 13.4. 
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The last Form in the wizard is the "Options" Form, Figure 13.4. In this Form, ELPLA displays some 

available options corresponding to the chosen numerical model, which differ from model to other. 

Select "Supports/ Boundary Conditions", then click the "Save" button. 

 

 
Figure 13.4 "Options" Form 

After clicking "Save" button, the "Save as" dialog box appears, Figure 13.5. In this dialog box 

type a file name for the current project in "File name" edit box. For example,  

type "Silo". ELPLA will use automatically this file name in all reading and writing processes. 
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Figure 13.5 "Save as" dialog box 

ELPLA will activate the “Data” Tab. In addition, the file name of the current project  

[Silo] will be displayed instead of the word [Untitled] in the ELPLA title bar. 
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5.2 Project identification 

The user can enter three lines of texts to describe the problem and the basic information about the task. 

These texts are required only for printing and plotting the data and results. Project identification 

does not play any role in the analysis. The three lines are optionally and maybe not completely entered. 

To identify the project, choose "Project Identification" command from the “Data” Tab. 

The dialog box in Figure 13.6 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box:  

"Analysis of a circular silo for storing bulk materials" 

- Type the date of the project in the "Date" edit box 

- Type "Axisymmetric Structures and Tanks" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 13.6 "Project Identification" dialog box 

5.3 FE-Net data 

For the given problem, a circular concrete silo having a conical hopper at the bottom part  

and a conical roof at the upper part is considered. The main height of the silo is 8 [m] and its 

diameter is 4 [m], The wall of the silo is divided into three parts, these three parts are divided  

into 14 segments; each segment is 1.0 [m]. Then these segments are divided into a number of 

elements, each element is 0.1 [m]. To define the FE-Net for this silo, choose "FE-Net Data" command 

from the “Data” Tab. "Analysis of rotational shell" wizard appears as shown in Figure 13.7.  

This wizard will guide you through the steps required to generate a FE-Net, the first Form  

of the wizard is the "Shell type" Form, which contains a group of templates of different shapes of nets.  

These net templates are used to generate standard nets. 
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Figure 13.7 "Analysis of rotational shell" wizard with "Shell type" Form 

To generate the FE-Net 

 

- In the "Shell type" options choose "Irregular shell" button 

- Type 0.25 in the "Tank base radius Rb" edit box, as the opening diameter at the bottom is 0.5 [m] 

 

To identify the hopper part  

 

• Type 3 in the "Height Hw" edit box 

• Type 2 in the "Upper radius Ro" edit box 

• Type 3 in the "Number of segments Ns" edit box 
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To identify the main wall  

 

• Type 8 in the "Height Hw" edit box 

• Type 2 in the "Upper radius Ro" edit box 

• Type 8 in the "Number of segments Ns" edit box 

 

To identify the roof part  

 

• Type 3 in the "Height Hw" edit box 

• Type 0.1 in the "Upper radius Ro" edit box, which is approximately zero 

• Type 3 in the "Number of segments Ns" edit box 

 

- Click "Next" button to go to the next Form 

 

After clicking "Next" in "Analysis of rotational shell" wizard, the following "Irregular shell" Form 

containing the data of the segments appears in Figure 13.8, the user can edit the data of each 

segment individually or all of them by using "In Table" button, if it is necessary. 
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Figure 13.8 "Irregular shell" Form 

Click "Finish" in "Analysis of rotational shell" wizard, the generated FE-Net appears Figure 13.9. 
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Figure 13.9 Generated FE-Net  

After finishing the generation of the FE-Net, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 13.9 to save the data of the FE-Net 

- Choose "Close" command from "File" menu in Figure 13.9 to close the "FE-Net" window 

and return to ELPLA main window 
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5.4 Shell properties 

To define the silo properties, choose "Shell Properties" command from “Data” Tab. The following 

window in Figure 13.10 appears with default shell properties. The data of shell properties for the 

current example, which are required to be defined, are element groups, group regions, unit weight  

of the silo material, filled material properties and element size. 

 

 
Figure 13.10 "Shell Properties" Window 

Choose "Element groups" command from "In table" menu. The following list box in Figure 13.11 

appears. In this list box, define E-Modulus, Poisson’s ratio and slab thickness for both the wall and  

the hopper of the silo as they differ in thickness. Then click "OK" button. 
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Figure 13.11 "Defining element groups" list box 

Defining the slab thickness for materials on the net may be carried out either graphically or numerically 

(in a table). In the current example, the user will define the slab thickness on the net graphically. 

 

To define the slab thickness for the silo hopper  

 

- Choose "Select Elements" command from "Graphically" menu in the window of Figure 13.10 

- When "Select Elements" command is chosen, the cursor will change from an arrow to  

a cross hair. A group of elements can be selected by holding the left mouse button down at the 

corner of the region. Then, drag the mouse until a rectangle encompasses the required group of 

elements. When the left mouse button is released, all elements in the rectangle are selected 

- Select the elements that include the silo hopper as Figure 13.12 

- Choose "Elements Groups" command from "Graphically" menu in the window of Figure 13.10, 

"Group Regions" dialog box Figure 13.13 appears 

- Define the "Group No." of the hopper elements as type "2", while "Group No." of the wall 

and the roof elements will be as type "1", where type "1" is the default "Group No.",  

then click "OK" button 
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Figure 13.12 Selecting the elements that include the silo hopper 

 
Figure 13.13 "Group Regions" dialog box 
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To enter the unit weight of the silo material, choose "Unit weight" command from "Shell 

Properties" menu in Figure 13.10. The following dialog box in Figure 13.14 with a default unit 

weight of 25 [kN/m3] appears, type 23.5 in the "Unit weight" edit box, then click "OK" button. 

 

 
Figure 13.14 "Unit weight" dialog box 
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To define the filled material properties: 

 

- Choose "Filled material type/Element size" command from "Shell Properties" menu in Figure 13.10. 

The following form in Figure 13.15 appears 

- Select "Granular material container" option 

- Define the granular material properties as follows in Figure 13.15 

 

To define the element size of the container: 

 

- Check the "Constant element sizes in z-direction" check box 

- Type 0.2 in the "Element size in each shell segment" edit box 

- Click "OK" button 

 

 
Figure 13.15 "Filled material type/Element size" Form 
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Figure 13.16 "Shell Properties" window after defining the silo properties 

After entering the shell properties, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 13.16 to save the shell properties 

- Choose "Close" command from "File" menu in Figure 13.16 to close the "Shell 

properties" window and return to ELPLA main window 
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5.5 Supports/ boundary conditions 

To define the support, choose "Supports/ Boundary Conditions" command from “Data” Tab.  

The following window in Figure 13.17 appears. 

 

 
Figure 13.17 "Supports/ Boundary Conditions" Window 

To define the support on the net: 

 

- Choose "Select Nodes" command from "Graphically" menu in Figure 13.17. When "Select 

Nodes" command is chosen, the cursor will change from an arrow to a cross hair 

- Click the left mouse button on the node that has the support as shown in Figure 13.18 

- After selecting the node, choose "Add Supports/ Boundary Conditions" command  

from "Graphically" menu (Figure 13.17). The "Supports/ Boundary Conditions" dialog box 

in Figure 13.19 appears 
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Figure 13.18 Selection of the node that has the support 
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In this dialog box 

 

- Type 0 in the "Displacement w" edit box to define the vertical fixed support 

- Click "OK" button 

 

 
Figure 13.19 "Supports/ Boundary Conditions" dialog box 
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Figure 13.20 "Supports/ Boundary Conditions" window after defining the supports 

After defining the supports, do the following two steps 

 

- Choose "Save " command from "File" menu in Figure 13.20 to save the data of supports 

- Choose "Close" command from "File" menu in Figure 13.20 to close the "Supports/ 

Boundary conditions" window and return to the main window 
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5.6 Loads 

To define the loads, choose "Loads" command from “Data” Tab. The following window  
in Figure 13.21 appears. 
 
In ELPLA, entering loads may be carried out either numerically (in a table) or graphically using the 
commands of "Loads" Tab in Figure 13.21. In this example, there is not applied load, as the lateral 
load on the main wall has been already defined by Ph. 
 

 
Figure 13.21 "Loads" Window 

After finishing the definition of load data, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 13.21 to save the load data 

- Choose "Close" command from "File" menu in Figure 13.21 to close the "Loads" window 

and return to ELPLA main window 

 

Creating the project of the silo is now complete. It is time to analyze this project.  

In the next section, you will learn how to use ELPLA for analyzing projects. 
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6 Carrying out the calculations 

To analyze the problem, switch to "Solver" Tab, Figure 13.22. 

 

 
Figure 13.22 "Solver" Tab 

ELPLA will active the "Individual Calculations" list, which contains commands of all calculations. 

Commands of calculation depend on the used calculation method in the analysis. For this project, 

the items that are required to be calculated are: 

 

- Assembling the load vector 

- Assembling the slab stiffness matrix 

- Solving the system of linear equations (band matrix)  

- Determining deformation, internal forces, contact pressures 

 

These calculation items can be carried out individually or in one time 

 

To carry out all computations in one time 

 

- Choose "Computation of all" command from "Solver" Tab window.  

 

The progress of all computations according to the defined method will be carried out automatically 

with displaying Information through menus and messages. 

 

Analysis progress 

 

Analysis progress menu in Figure 13.23 appears in which various phases of calculation  

are progressively reported as the program analyzes the problem. In addition, a status bar down  

of the "Solver" Tab window displays Information about the progress of calculation. 

 

 
Figure 13.23 Analysis progress menu 
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Check of the solution 

 

Once the analysis is carried out, a check menu of the solution appears, Figure 13.24. This menu 

compares between the values of actions and reactions. Through this comparative examination,  

the user can assess the calculation accuracy.  

 

 
Figure 13.24 Menu "Check of the solution" 

 

Click "OK" button to finish analyzing the problem. 
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7 Viewing data and results 

ELPLA can display and print a wide variety of results in graphics, diagrams or tables through  

the "Results" Tab. To view the data and results of a problem that has already been defined  

and analyzed graphically, switch to "Results" Tab (Figure 13.25). 

 

 
Figure 13.25 "Results" Tab 

The "Result" Tab contains the commands of drawing. These commands depend on the used 

calculation method in the analysis. For the current example, the commands for presenting the data 

and results are: 

 

- Data in the plan 

- Rotational shell results 

- Support Reactions 

- Sections in shell wall 

- Display tables of data 

- Display tables of results 

 

To view the radial forces on the silo wall  

 

- Choose "Sections in shell wall" command from "Section" menu. The following option box 

in Figure 13.26 appears 

- In the "Sections in shell wall" option box, select "Radial forces Nr" as an example for the 

results to be displayed 

- Click "OK" button 

 

The Results are now displayed as shown in Figure 13.27. 
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Figure 13.26 "Sections in shell wall" option box 

 

 
Figure 13.27 Radial forces on the silo wall 

 

 

 

 

 

 

 

 

 

 

 



Example 13  

 

 

   -13.29- 

To view element groups of the silo  

 

- Choose "Element groups" from "In Plan" command in "Data" menu. The following option 

box in Figure 13.28 appears 

- In the "Data – In Plan" option box, select "Element groups" as an example for the results  

to be displayed 

- Click "OK" button 

 

 
Figure 13.28 "Data – In Plan" option box 

To view the supports / boundary conditions on the FE-Net and any other data 

 

- From "Options" menu in the "Graphic" tab, choose "View Grouping" command.  

The "View Grouping" check group box in Figure 13.29 appears 

- In this check group box, check ''Radial forces Nr", "Supports Reactions RV" and "Supports 

/Boundary Conditions" check boxes  

- The user can choose any other data to be viewed 

- Click "OK" button 

 

 
Figure 13.29 "View Grouping" check group box 
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Figure 13.30 Element groups of the silo 

 

 

 

 

 

 

 

 

 

 

 

 

 

 


